{"action":"Upgrade phpoffice/phpspreadsheet to 1.29.1 or later.","affected":[{"fixed":"2.1.0","introduced":"2.0.0"},{"fixed":"1.29.1","introduced":"0"}],"component":"phpoffice/phpspreadsheet","cve_ids":["CVE-2024-45046"],"ecosystem":"Packagist","epss":0.00418,"exploited":false,"fixed_versions":["2.1.0","1.29.1"],"ghsa_id":"GHSA-wgmf-q9vr-vww6","id":"tcs_01M5KFA2GTDAZDB3JWZESV706M","modified_at":"2025-03-06T18:36:59.605226Z","published_at":"2024-08-29T17:56:56Z","references":["https://osv.dev/vulnerability/GHSA-wgmf-q9vr-vww6","https://github.com/PHPOffice/PhpSpreadsheet/security/advisories/GHSA-wgmf-q9vr-vww6","https://nvd.nist.gov/vuln/detail/CVE-2024-45046","https://github.com/PHPOffice/PhpSpreadsheet/pull/3957","https://github.com/PHPOffice/PhpSpreadsheet/commit/f7cf378faed2e11cf4825bf8bafea4922ae44667","https://github.com/PHPOffice/PhpSpreadsheet"],"severity":{"label":"medium","score":5.4},"sources":[{"source":"osv","source_id":"GHSA-wgmf-q9vr-vww6","url":"https://osv.dev/vulnerability/GHSA-wgmf-q9vr-vww6"}],"summary":"PhpSpreadsheet HTML writer is vulnerable to Cross-Site Scripting via style information"}