{"action":"Upgrade github.com/mattermost/mattermost-server to 3.9.2 or later.","affected":[{"fixed":"3.9.2","introduced":"0"},{"fixed":"3.10.2","introduced":"3.10.0"}],"component":"github.com/mattermost/mattermost-server","cve_ids":["CVE-2017-18905"],"ecosystem":"Go","epss":0.00775,"exploited":false,"fixed_versions":["3.9.2","3.10.2"],"ghsa_id":"GHSA-g24c-fx4v-xg9w","id":"tcs_01M5KFA36MXM774RS70MBT6XS7","modified_at":"2026-02-03T03:02:11.022673Z","published_at":"2022-05-24T17:21:06Z","references":["https://osv.dev/vulnerability/GHSA-g24c-fx4v-xg9w","https://nvd.nist.gov/vuln/detail/CVE-2017-18905","https://github.com/mattermost/mattermost/commit/15ad24d160cb4604d0605ebbfa53d11a57820706","https://github.com/mattermost/mattermost/commit/b17fca0d5ee7557e3df1cf1d1da8bd749859e35f","https://github.com/mattermost/mattermost/commit/fbc170733e86f09b46ba754dd03304733d2f482f","https://github.com/mattermost/mattermost","https://mattermost.com/security-updates"],"severity":{"label":"medium","score":5.3},"sources":[{"source":"osv","source_id":"GHSA-g24c-fx4v-xg9w","url":"https://osv.dev/vulnerability/GHSA-g24c-fx4v-xg9w"}],"summary":"Mattermost Server has Insufficient Session Expiration when used as an OAuth 2.0 service provider"}