{"action":"Upgrade glances to 4.5.5 or later.","affected":[{"fixed":"4.5.5","introduced":"0"}],"component":"glances","cve_ids":["CVE-2026-46607"],"ecosystem":"PyPI","epss":0.0019,"exploited":false,"fixed_versions":["4.5.5"],"ghsa_id":"GHSA-9837-48hr-q32j","id":"tcs_01M5KFA5PPBFZ033YQE665R7ZA","modified_at":"2026-07-21T15:00:42.382802312Z","published_at":"2026-06-22T21:21:07Z","references":["https://osv.dev/vulnerability/GHSA-9837-48hr-q32j","https://github.com/nicolargo/glances/security/advisories/GHSA-9837-48hr-q32j","https://nvd.nist.gov/vuln/detail/CVE-2026-46607","https://github.com/advisories/GHSA-9837-48hr-q32j","https://github.com/nicolargo/glances","https://github.com/nicolargo/glances/releases/tag/v4.5.5","https://github.com/pypa/advisory-database/tree/main/vulns/glances/PYSEC-2026-2496.yaml","https://pypi.org/project/glances"],"severity":{"label":"high","score":7.8},"sources":[{"source":"osv","source_id":"GHSA-9837-48hr-q32j","url":"https://osv.dev/vulnerability/GHSA-9837-48hr-q32j"}],"summary":"Glances has Insecure Pickle Deserialization in its Version Cache that Leads to Arbitrary Code Execution"}