{"action":"Upgrade phpoffice/phpspreadsheet to 1.29.7 or later.","affected":[{"fixed":"3.7.0","introduced":"3.0.0"},{"fixed":"1.29.7","introduced":"0"},{"fixed":"2.1.6","introduced":"2.0.0"},{"fixed":"2.3.5","introduced":"2.2.0"}],"component":"phpoffice/phpspreadsheet","cve_ids":["CVE-2024-56410"],"ecosystem":"Packagist","epss":0.00337,"exploited":false,"fixed_versions":["3.7.0","1.29.7","2.1.6","2.3.5"],"ghsa_id":"GHSA-wv23-996v-q229","id":"tcs_01M5KFABQNEEQ8YPY1KFRB7CQD","modified_at":"2025-03-06T18:37:39.563941Z","published_at":"2025-01-03T17:25:45Z","references":["https://osv.dev/vulnerability/GHSA-wv23-996v-q229","https://github.com/PHPOffice/PhpSpreadsheet/security/advisories/GHSA-wv23-996v-q229","https://nvd.nist.gov/vuln/detail/CVE-2024-56410","https://github.com/PHPOffice/PhpSpreadsheet/commit/45052f88e04c735d56457a8ffcdc40b2635a028e","https://github.com/PHPOffice/PhpSpreadsheet"],"severity":{"label":"medium","score":5.4},"sources":[{"source":"osv","source_id":"GHSA-wv23-996v-q229","url":"https://osv.dev/vulnerability/GHSA-wv23-996v-q229"}],"summary":"PhpSpreadsheet has a Cross-Site Scripting (XSS) vulnerability in custom properties"}