{"action":"Upgrade moodle/moodle to 3.9.14 or later.","affected":[{"fixed":"4.0.1","introduced":"4.0"},{"fixed":"3.11.7","introduced":"3.11"},{"fixed":"3.10.11","introduced":"3.10"},{"fixed":"3.9.14","introduced":"3.9"}],"component":"moodle/moodle","cve_ids":["CVE-2022-30596"],"ecosystem":"Packagist","epss":0.00906,"exploited":false,"fixed_versions":["4.0.1","3.11.7","3.10.11","3.9.14"],"ghsa_id":"GHSA-wvh5-78h5-gmgr","id":"tcs_01M5KFACDGJ5G5E042G1D8XWVR","modified_at":"2024-02-17T05:32:05.393927Z","published_at":"2022-05-19T00:00:15Z","references":["https://osv.dev/vulnerability/GHSA-wvh5-78h5-gmgr","https://nvd.nist.gov/vuln/detail/CVE-2022-30596","https://github.com/moodle/moodle/commit/6abe964bbac41b5e40a81b40962f7044b0dc201e","https://bugzilla.redhat.com/show_bug.cgi?id=2083583","https://github.com/moodle/moodle","https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/OGF35EN5K2R6X3NTY3XPZSJ3UDASMXI6","https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/PIMSIRKCFLIC646K4GMUSZU7THOUVPAJ","https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/QCTWSE3JDMSYL7DPCMXMMJEXZSS6VIA5","https://moodle.org/mod/forum/discuss.php?d=434578","http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-74204"],"severity":{"label":"medium","score":5.4},"sources":[{"source":"osv","source_id":"GHSA-wvh5-78h5-gmgr","url":"https://osv.dev/vulnerability/GHSA-wvh5-78h5-gmgr"}],"summary":"Cross-site Scripting in moodle"}