{"action":"Upgrade theshit to 0.1.1 or later.","affected":[{"fixed":"0.1.1","introduced":"0.0.0-0"}],"component":"theshit","cve_ids":["CVE-2025-69257"],"ecosystem":"crates.io","epss":0.00134,"exploited":false,"fixed_versions":["0.1.1"],"ghsa_id":"GHSA-95qg-89c2-w5hj","id":"tcs_01M5KFAG2WZHE53WC8WE7DKDTM","modified_at":"2026-10-12T18:00:13.062721522Z","published_at":"2025-12-30T12:00:00Z","references":["https://osv.dev/vulnerability/RUSTSEC-2025-0139","https://crates.io/crates/theshit","https://rustsec.org/advisories/RUSTSEC-2025-0139.html","https://github.com/AsfhtgkDavid/theshit/commit/8e0b565e7876a83b0e1cfbacb8af39dadfdcc500"],"severity":{"label":"high","score":7.3},"sources":[{"source":"osv","source_id":"RUSTSEC-2025-0139","url":"https://osv.dev/vulnerability/RUSTSEC-2025-0139"}],"summary":"theshit vulnerable to unsafe loading of user-owned Python rules when running as root"}