{"action":"Upgrade tensorflow-cpu to 2.3.4 or later.","affected":[{"fixed":"2.3.4","introduced":"0"},{"fixed":"2.4.3","introduced":"2.4.0"},{"fixed":"2.5.1","introduced":"2.5.0"}],"component":"tensorflow-cpu","cve_ids":["CVE-2021-37641"],"ecosystem":"PyPI","epss":0.00167,"exploited":false,"fixed_versions":["2.3.4","2.4.3","2.5.1"],"ghsa_id":"GHSA-9c8h-vvrj-w2p8","id":"tcs_01M5KFAH5ZTC40F9C1XSK00TYW","modified_at":"2026-07-08T06:28:25.197492078Z","published_at":"2021-08-25T14:43:59Z","references":["https://osv.dev/vulnerability/GHSA-9c8h-vvrj-w2p8","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-9c8h-vvrj-w2p8","https://nvd.nist.gov/vuln/detail/CVE-2021-37641","https://github.com/tensorflow/tensorflow/commit/a2b743f6017d7b97af1fe49087ae15f0ac634373","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-554.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-752.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-263.yaml","https://github.com/tensorflow/tensorflow"],"severity":{"label":"high","score":7.1},"sources":[{"source":"osv","source_id":"GHSA-9c8h-vvrj-w2p8#PyPI/tensorflow-cpu","url":"https://osv.dev/vulnerability/GHSA-9c8h-vvrj-w2p8"}],"summary":"Heap OOB in `RaggedGather`"}