{"action":"Upgrade fast-uri to 2.4.4 or later.","affected":[{"fixed":"2.4.4","introduced":"0"},{"fixed":"3.1.5","introduced":"3.0.0"},{"fixed":"4.1.2","introduced":"4.0.0"}],"component":"fast-uri","cve_ids":["CVE-2026-18446"],"ecosystem":"npm","epss":0.0038,"exploited":false,"fixed_versions":["2.4.4","3.1.5","4.1.2"],"ghsa_id":"GHSA-7p8r-x3mc-p8w7","id":"tcs_01M5KFAHFZMT11K1C8Z1XEZ5YR","modified_at":"2026-09-10T03:50:53.468438344Z","published_at":"2026-08-03T19:16:43Z","references":["https://osv.dev/vulnerability/GHSA-7p8r-x3mc-p8w7","https://github.com/fastify/fast-uri/security/advisories/GHSA-7p8r-x3mc-p8w7","https://nvd.nist.gov/vuln/detail/CVE-2026-18446","https://github.com/fastify/fast-uri/commit/f3c6c905f47831007490f466c5945012e905cc52","https://cna.openjsf.org/security-advisories.html","https://github.com/fastify/fast-uri","https://github.com/fastify/fast-uri/releases/tag/v4.1.2"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-7p8r-x3mc-p8w7","url":"https://osv.dev/vulnerability/GHSA-7p8r-x3mc-p8w7"}],"summary":"fast-uri vulnerable to host confusion via backslash authority introducer"}