{"action":"Upgrade webssh to 1.6.3 or later.","affected":[{"fixed":"1.6.3","introduced":"0"}],"component":"webssh","cve_ids":["CVE-2025-7885"],"ecosystem":"PyPI","epss":0.00555,"exploited":false,"fixed_versions":["1.6.3"],"ghsa_id":"GHSA-9cg4-9hv5-3376","id":"tcs_01M5KFAJ354W1N1KT0CPWK0KXM","modified_at":"2026-06-08T20:00:14.508064757Z","published_at":"2025-07-20T12:30:27Z","references":["https://osv.dev/vulnerability/GHSA-9cg4-9hv5-3376","https://nvd.nist.gov/vuln/detail/CVE-2025-7885","https://github.com/huashengdun/webssh/issues/410","https://github.com/huashengdun/webssh/commit/a7a704f111391c82efc1bacf89693ff45bda7f5f","https://github.com/4m3rr0r/PoCVulDb/blob/main/CVE-2025-7885.md","https://github.com/huashengdun/webssh","https://github.com/pypa/advisory-database/tree/main/vulns/webssh/PYSEC-2025-234.yaml","https://vuldb.com/?ctiid.317000","https://vuldb.com/?id.317000","https://vuldb.com/?submit.613610"],"severity":{"label":"medium","score":4.3},"sources":[{"source":"osv","source_id":"GHSA-9cg4-9hv5-3376","url":"https://osv.dev/vulnerability/GHSA-9cg4-9hv5-3376"}],"summary":"WebSSH Cross-site Scripting vulnerability"}