{"action":"Upgrade tensorflow-gpu to 2.4.4 or later.","affected":[{"fixed":"2.6.1","introduced":"2.6.0"},{"fixed":"2.5.2","introduced":"2.5.0"},{"fixed":"2.4.4","introduced":"0"}],"component":"tensorflow-gpu","cve_ids":["CVE-2021-41218"],"ecosystem":"PyPI","epss":0.00133,"exploited":false,"fixed_versions":["2.6.1","2.5.2","2.4.4"],"ghsa_id":"GHSA-9crf-c6qr-r273","id":"tcs_01M5KFAMMQK14YXVZ1Z7A7REB0","modified_at":"2026-07-08T06:29:28.866607143Z","published_at":"2021-11-10T18:52:24Z","references":["https://osv.dev/vulnerability/GHSA-9crf-c6qr-r273","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-9crf-c6qr-r273","https://nvd.nist.gov/vuln/detail/CVE-2021-41218","https://github.com/tensorflow/tensorflow/commit/a8ad3e5e79c75f36edb81e0ba3f3c0c5442aeddc","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-627.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-825.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-410.yaml","https://github.com/tensorflow/tensorflow"],"severity":{"label":"medium","score":5.5},"sources":[{"source":"osv","source_id":"GHSA-9crf-c6qr-r273#PyPI/tensorflow-gpu","url":"https://osv.dev/vulnerability/GHSA-9crf-c6qr-r273"}],"summary":"Integer division by 0 in `tf.raw_ops.AllToAll`"}