{"action":"Upgrade codeigniter4/framework to 4.5.8 or later.","affected":[{"fixed":"4.5.8","introduced":"0"}],"component":"codeigniter4/framework","cve_ids":["CVE-2025-24013"],"ecosystem":"Packagist","epss":0.00508,"exploited":false,"fixed_versions":["4.5.8"],"ghsa_id":"GHSA-x5mq-jjr3-vmx6","id":"tcs_01M5KFAPE432YXWQ79687P34D5","modified_at":"2026-02-04T04:21:17.711108Z","published_at":"2025-01-21T21:13:40Z","references":["https://osv.dev/vulnerability/GHSA-x5mq-jjr3-vmx6","https://github.com/codeigniter4/CodeIgniter4/security/advisories/GHSA-x5mq-jjr3-vmx6","https://nvd.nist.gov/vuln/detail/CVE-2025-24013","https://github.com/codeigniter4/CodeIgniter4/commit/5f8aa24280fb09947897d6b322bf1f0e038b13b6","https://datatracker.ietf.org/doc/html/rfc7230#section-3.2","https://github.com/advisories/GHSA-wxmh-65f7-jcvw","https://github.com/codeigniter4/CodeIgniter4"],"severity":{"label":"medium","score":5.3},"sources":[{"source":"osv","source_id":"GHSA-x5mq-jjr3-vmx6","url":"https://osv.dev/vulnerability/GHSA-x5mq-jjr3-vmx6"}],"summary":"Missing validation of header name and value in codeigniter4/framework"}