{"action":"Upgrade composer/composer to 1.10.26 or later.","affected":[{"fixed":"1.10.26","introduced":"0"},{"fixed":"2.2.12","introduced":"2.0"},{"fixed":"2.3.5","introduced":"2.3"}],"component":"composer/composer","cve_ids":["CVE-2022-24828"],"ecosystem":"Packagist","epss":0.01886,"exploited":false,"fixed_versions":["1.10.26","2.2.12","2.3.5"],"ghsa_id":"GHSA-x7cr-6qr6-2hh6","id":"tcs_01M5KFAT0JZ25ZJSXSZ4E83ND3","modified_at":"2024-02-21T05:32:42.447669Z","published_at":"2022-04-22T20:15:38Z","references":["https://osv.dev/vulnerability/GHSA-x7cr-6qr6-2hh6","https://github.com/composer/composer/security/advisories/GHSA-x7cr-6qr6-2hh6","https://nvd.nist.gov/vuln/detail/CVE-2022-24828","https://github.com/composer/composer/commit/2c40c53637c5c7e43fff7c09d3d324d632734709","https://github.com/FriendsOfPHP/security-advisories/blob/master/composer/composer/CVE-2022-24828.yaml","https://github.com/composer/composer","https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/625MT3IKWKFVIWLSYZFSXHVUA2LES7YQ","https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/GWT6LDSRY7SFMTDZWJ4MS2ZBXHL7VQEF","https://lists.fedoraproject.org/archives/list/package-announce@lists.fedoraproject.org/message/QD7JQWL6C4GVROO25DTXWYWM6BPOPPCG","https://www.tenable.com/security/tns-2022-09"],"severity":{"label":"high","score":8.3},"sources":[{"source":"osv","source_id":"GHSA-x7cr-6qr6-2hh6","url":"https://osv.dev/vulnerability/GHSA-x7cr-6qr6-2hh6"}],"summary":"Missing input validation can lead to command execution in composer"}