{"action":"Upgrade github.com/hashicorp/vault to 1.19.3 or later.","affected":[{"fixed":"1.19.3","introduced":"0.3.0"}],"component":"github.com/hashicorp/vault","cve_ids":["CVE-2025-4166"],"ecosystem":"Go","epss":0.00449,"exploited":false,"fixed_versions":["1.19.3"],"ghsa_id":"GHSA-gcqf-f89c-68hv","id":"tcs_01M5KFAVK0MJZZEPH17Y1REPJF","modified_at":"2026-09-10T03:50:57.562022580Z","published_at":"2025-05-02T15:31:49Z","references":["https://osv.dev/vulnerability/GHSA-gcqf-f89c-68hv","https://nvd.nist.gov/vuln/detail/CVE-2025-4166","https://discuss.hashicorp.com/t/hcsec-2025-09-vault-may-expose-sensitive-information-in-error-logs-when-processing-malformed-data-with-the-kv-v2-plugin","https://github.com/hashicorp/vault","https://pkg.go.dev/vuln/GO-2025-3663"],"severity":{"label":"medium","score":4.5},"sources":[{"source":"osv","source_id":"GHSA-gcqf-f89c-68hv","url":"https://osv.dev/vulnerability/GHSA-gcqf-f89c-68hv"}],"summary":"Hashicorp Vault Community vulnerable to Generation of Error Message Containing Sensitive Information"}