{"action":"Upgrade symfony/symfony to 5.4.46 or later.","affected":[{"fixed":"5.4.46","introduced":"5.3.0"},{"fixed":"6.4.14","introduced":"6.0.0"},{"fixed":"7.1.7","introduced":"7.0.0"}],"component":"symfony/symfony","cve_ids":["CVE-2024-50340"],"ecosystem":"Packagist","epss":0.61834,"exploited":false,"fixed_versions":["5.4.46","6.4.14","7.1.7"],"ghsa_id":"GHSA-x8vp-gf4q-mw5j","id":"tcs_01M5KFAW87BPQ9B73B0B4VZ4PY","modified_at":"2024-11-07T00:01:50.475915Z","published_at":"2024-11-06T15:11:07Z","references":["https://osv.dev/vulnerability/GHSA-x8vp-gf4q-mw5j","https://github.com/symfony/symfony/security/advisories/GHSA-x8vp-gf4q-mw5j","https://nvd.nist.gov/vuln/detail/CVE-2024-50340","https://github.com/symfony/symfony/commit/a77b308c3f179ed7c8a8bc295f82b2d6ee3493fa","https://github.com/FriendsOfPHP/security-advisories/blob/master/symfony/runtime/CVE-2024-50340.yaml","https://github.com/FriendsOfPHP/security-advisories/blob/master/symfony/symfony/CVE-2024-50340.yaml","https://github.com/symfony/symfony","https://symfony.com/cve-2024-50340"],"severity":{"label":"high","score":7.3},"sources":[{"source":"osv","source_id":"GHSA-x8vp-gf4q-mw5j#Packagist/symfony/symfony","url":"https://osv.dev/vulnerability/GHSA-x8vp-gf4q-mw5j"}],"summary":"Symfony allows changing the environment through a query"}