{"action":"Upgrade vllm to 0.9.0 or later.","affected":[{"fixed":"0.9.0","introduced":"0.8.0"}],"component":"vllm","cve_ids":["CVE-2025-48943"],"ecosystem":"PyPI","epss":0.00508,"exploited":false,"fixed_versions":["0.9.0"],"ghsa_id":"GHSA-9hcf-v7m4-6m2j","id":"tcs_01M5KFAXTCZSXQWR6HPVSEZW50","modified_at":"2026-08-07T08:12:07.476205432Z","published_at":"2025-05-28T19:42:12Z","references":["https://osv.dev/vulnerability/GHSA-9hcf-v7m4-6m2j","https://github.com/vllm-project/vllm/security/advisories/GHSA-9hcf-v7m4-6m2j","https://nvd.nist.gov/vuln/detail/CVE-2025-48943","https://github.com/vllm-project/vllm/issues/17313","https://github.com/vllm-project/vllm/pull/17623","https://github.com/vllm-project/vllm/commit/08bf7840780980c7568c573c70a6a8db94fd45ff","https://github.com/pypa/advisory-database/tree/main/vulns/vllm/PYSEC-2025-55.yaml","https://github.com/vllm-project/vllm"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"GHSA-9hcf-v7m4-6m2j","url":"https://osv.dev/vulnerability/GHSA-9hcf-v7m4-6m2j"}],"summary":"vLLM allows clients to crash the openai server with invalid regex"}