{"action":"Upgrade dirac to 8.0.79 or later.","affected":[{"fixed":"8.0.79","introduced":"6"},{"fixed":"9.0.22","introduced":"8.1.0a1"},{"fixed":"9.1.10","introduced":"9.1.0"}],"component":"dirac","cve_ids":["CVE-2026-45579"],"ecosystem":"PyPI","epss":0.00864,"exploited":false,"fixed_versions":["8.0.79","9.0.22","9.1.10"],"ghsa_id":"GHSA-9jpv-c7p4-997x","id":"tcs_01M5KFB3QM0H8PTCKTA3P94Z3B","modified_at":"2026-07-23T15:11:46.251064004Z","published_at":"2026-07-13T17:20:18Z","references":["https://osv.dev/vulnerability/GHSA-9jpv-c7p4-997x","https://github.com/DIRACGrid/DIRAC/security/advisories/GHSA-9jpv-c7p4-997x","https://github.com/DIRACGrid/DIRAC","https://pypi.org/project/DIRAC/8.0.79","https://pypi.org/project/DIRAC/9.0.22","https://pypi.org/project/DIRAC/9.1.10"],"severity":{"label":"critical","score":9.9},"sources":[{"source":"osv","source_id":"GHSA-9jpv-c7p4-997x","url":"https://osv.dev/vulnerability/GHSA-9jpv-c7p4-997x"}],"summary":"DIRAC is vulnerable to RCE in RequestManager due to eval on untrusted input"}