{"action":"Upgrade keylime to 7.12.1 or later.","affected":[{"fixed":"7.12.1","introduced":"7.12.0"}],"component":"keylime","cve_ids":["CVE-2025-1057"],"ecosystem":"PyPI","epss":0.00399,"exploited":false,"fixed_versions":["7.12.1"],"ghsa_id":"GHSA-9jxq-5x44-gx23","id":"tcs_01M5KFB458NS11B4HM5G5M1RBP","modified_at":"2026-07-21T15:00:40.984348779Z","published_at":"2025-02-14T18:03:14Z","references":["https://osv.dev/vulnerability/GHSA-9jxq-5x44-gx23","https://github.com/keylime/keylime/security/advisories/GHSA-9jxq-5x44-gx23","https://nvd.nist.gov/vuln/detail/CVE-2025-1057","https://github.com/keylime/keylime/commit/e08b10d86c3717006774e787542c190e2ba24fc7","https://access.redhat.com/security/cve/CVE-2025-1057","https://bugzilla.redhat.com/show_bug.cgi?id=2343894","https://github.com/advisories/GHSA-9jxq-5x44-gx23","https://github.com/ansasaki/keylime/tree/base64_bytes","https://github.com/keylime/keylime","https://github.com/keylime/rust-keylime","https://github.com/pypa/advisory-database/tree/main/vulns/keylime/PYSEC-2026-1488.yaml","https://pypi.org/project/keylime"],"severity":{"label":"medium","score":4.3},"sources":[{"source":"osv","source_id":"GHSA-9jxq-5x44-gx23","url":"https://osv.dev/vulnerability/GHSA-9jxq-5x44-gx23"}],"summary":"Keylime registrar is vulnerable to Denial-of-Service attack when updated to version 7.12.0"}