{"action":"Upgrade codeigniter4/framework to 4.1.9 or later.","affected":[{"fixed":"4.1.9","introduced":"0"}],"component":"codeigniter4/framework","cve_ids":["CVE-2022-24711"],"ecosystem":"Packagist","epss":0.01173,"exploited":false,"fixed_versions":["4.1.9"],"ghsa_id":"GHSA-xjp4-6w75-qrj7","id":"tcs_01M5KFB4F2JQY455QV65HWTGD7","modified_at":"2024-02-16T08:12:24.956129Z","published_at":"2022-03-01T21:44:13Z","references":["https://osv.dev/vulnerability/GHSA-xjp4-6w75-qrj7","https://github.com/codeigniter4/CodeIgniter4/security/advisories/GHSA-xjp4-6w75-qrj7","https://nvd.nist.gov/vuln/detail/CVE-2022-24711","https://github.com/codeigniter4/CodeIgniter4/commit/202f41ad522ba1d414b9d9c35aba1cb0c156b781","https://github.com/FriendsOfPHP/security-advisories/blob/master/codeigniter4/framework/CVE-2022-24711.yaml","https://github.com/codeigniter4/CodeIgniter4"],"severity":{"label":"critical","score":9.4},"sources":[{"source":"osv","source_id":"GHSA-xjp4-6w75-qrj7","url":"https://osv.dev/vulnerability/GHSA-xjp4-6w75-qrj7"}],"summary":"Remote CLI Command Execution Vulnerability in CodeIgniter4"}