{"action":"Upgrade tensorflow to 1.15.4 or later.","affected":[{"fixed":"1.15.4","introduced":"0"},{"fixed":"2.0.3","introduced":"2.0.0"},{"fixed":"2.1.2","introduced":"2.1.0"},{"fixed":"2.2.1","introduced":"2.2.0"},{"fixed":"2.3.1","introduced":"2.3.0"}],"component":"tensorflow","cve_ids":["CVE-2020-15194"],"ecosystem":"PyPI","epss":0.01026,"exploited":false,"fixed_versions":["1.15.4","2.0.3","2.1.2","2.2.1","2.3.1"],"ghsa_id":"GHSA-9mqp-7v2h-2382","id":"tcs_01M5KFB6KHQA42V43KJKXAXP07","modified_at":"2026-07-08T06:28:25.050512524Z","published_at":"2020-09-25T18:28:19Z","references":["https://osv.dev/vulnerability/GHSA-9mqp-7v2h-2382","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-9mqp-7v2h-2382","https://nvd.nist.gov/vuln/detail/CVE-2020-15194","https://github.com/tensorflow/tensorflow/commit/390611e0d45c5793c7066110af37c8514e6a6c54","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2020-274.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2020-309.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2020-117.yaml","https://github.com/tensorflow/tensorflow","https://github.com/tensorflow/tensorflow/releases/tag/v2.3.1","http://lists.opensuse.org/opensuse-security-announce/2020-10/msg00065.html"],"severity":{"label":"medium","score":5.3},"sources":[{"source":"osv","source_id":"GHSA-9mqp-7v2h-2382","url":"https://osv.dev/vulnerability/GHSA-9mqp-7v2h-2382"}],"summary":"Denial of Service in Tensorflow"}