{"action":"Upgrade esphome to 2024.2.2 or later.","affected":[{"fixed":"2024.2.2","introduced":"2023.12.9"}],"component":"esphome","cve_ids":["CVE-2024-27287"],"ecosystem":"PyPI","epss":0.00681,"exploited":false,"fixed_versions":["2024.2.2"],"ghsa_id":"GHSA-9p43-hj5j-96h5","id":"tcs_01M5KFB7WFDTRDG4VN56PZW76P","modified_at":"2026-07-07T17:57:03.701022430Z","published_at":"2024-03-06T15:28:21Z","references":["https://osv.dev/vulnerability/GHSA-9p43-hj5j-96h5","https://github.com/esphome/esphome/security/advisories/GHSA-9p43-hj5j-96h5","https://github.com/esphome/esphome/commit/37d2b3c7977a4ccbec59726ca7549cb776661455","https://github.com/esphome/esphome"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"GHSA-9p43-hj5j-96h5","url":"https://osv.dev/vulnerability/GHSA-9p43-hj5j-96h5"}],"summary":"esphome vulnerable to stored Cross-site Scripting in edit configuration file API"}