{"action":"Upgrade moodle/moodle to 4.1.10 or later.","affected":[{"fixed":"4.3.4","introduced":"4.3.0"},{"fixed":"4.2.7","introduced":"4.2.0"},{"fixed":"4.1.10","introduced":"0"}],"component":"moodle/moodle","cve_ids":["CVE-2024-33998"],"ecosystem":"Packagist","epss":0.0037,"exploited":false,"fixed_versions":["4.3.4","4.2.7","4.1.10"],"ghsa_id":"GHSA-xqhh-253w-4q5f","id":"tcs_01M5KFB93295BGQ3SR6P93E76B","modified_at":"2025-05-31T06:26:55.057149Z","published_at":"2024-05-31T21:30:52Z","references":["https://osv.dev/vulnerability/GHSA-xqhh-253w-4q5f","https://nvd.nist.gov/vuln/detail/CVE-2024-33998","https://github.com/moodle/moodle/commit/66da9394993d97861f6c80bc4ec4ee9b513d2f33","https://github.com/moodle/moodle","https://moodle.org/mod/forum/discuss.php?d=458386","http://git.moodle.org/gw?p=moodle.git&a=search&h=HEAD&st=commit&s=MDL-81354"],"severity":{"label":"medium","score":5.4},"sources":[{"source":"osv","source_id":"GHSA-xqhh-253w-4q5f","url":"https://osv.dev/vulnerability/GHSA-xqhh-253w-4q5f"}],"summary":"Moodle Cross-site Scripting (XSS)"}