{"action":"Upgrade vllm to 0.10.0 or later.","affected":[{"fixed":"0.10.0","introduced":"0.5.2"}],"component":"vllm","cve_ids":["CVE-2025-30165"],"ecosystem":"PyPI","epss":0.00562,"exploited":false,"fixed_versions":["0.10.0"],"ghsa_id":"GHSA-9pcc-gvx5-r5wm","id":"tcs_01M5KFB9AQMC0132B4MVNWGPYR","modified_at":"2026-08-07T08:12:19.063707308Z","published_at":"2025-05-06T16:38:35Z","references":["https://osv.dev/vulnerability/GHSA-9pcc-gvx5-r5wm","https://github.com/vllm-project/vllm/security/advisories/GHSA-9pcc-gvx5-r5wm","https://nvd.nist.gov/vuln/detail/CVE-2025-30165","https://github.com/advisories/GHSA-9pcc-gvx5-r5wm","https://github.com/pypa/advisory-database/tree/main/vulns/vllm/PYSEC-2026-2017.yaml","https://github.com/vllm-project/vllm","https://github.com/vllm-project/vllm/blob/c21b99b91241409c2fdf9f3f8c542e8748b317be/vllm/distributed/device_communicators/shm_broadcast.py#L295-L301","https://github.com/vllm-project/vllm/blob/c21b99b91241409c2fdf9f3f8c542e8748b317be/vllm/distributed/device_communicators/shm_broadcast.py#L468-L470","https://pypi.org/project/vllm"],"severity":{"label":"high","score":8},"sources":[{"source":"osv","source_id":"GHSA-9pcc-gvx5-r5wm","url":"https://osv.dev/vulnerability/GHSA-9pcc-gvx5-r5wm"}],"summary":"Remote Code Execution Vulnerability in vLLM Multi-Node Cluster Configuration"}