{"action":"Upgrade pannellum to 2.5.7 or later.","affected":[{"fixed":"2.5.7","introduced":"2.5.0"}],"component":"pannellum","cve_ids":["CVE-2026-27210"],"ecosystem":"npm","epss":0.00368,"exploited":false,"fixed_versions":["2.5.7"],"ghsa_id":"GHSA-8423-w5wx-h2r6","id":"tcs_01M5KFBKVVYHSRYH4BSDXQ8JSB","modified_at":"2026-02-23T23:43:43.699402Z","published_at":"2026-02-19T20:44:48Z","references":["https://osv.dev/vulnerability/GHSA-8423-w5wx-h2r6","https://github.com/mpetroff/pannellum/security/advisories/GHSA-8423-w5wx-h2r6","https://nvd.nist.gov/vuln/detail/CVE-2026-27210","https://github.com/mpetroff/pannellum/commit/9391ef8da6a6a98c6a9f8c97f101adb900523681","https://github.com/mpetroff/pannellum"],"severity":{"label":"medium","score":6.1},"sources":[{"source":"osv","source_id":"GHSA-8423-w5wx-h2r6","url":"https://osv.dev/vulnerability/GHSA-8423-w5wx-h2r6"},{"source":"nvd","source_id":"CVE-2026-27210","url":"https://nvd.nist.gov/vuln/detail/CVE-2026-27210"}],"summary":"Pannellum has a XSS vulnerability in hot spot attributes"}