{"action":"Upgrade tokio-postgres to 0.7.18 or later.","affected":[{"fixed":"0.7.18","introduced":"0.4.0"}],"component":"tokio-postgres","cve_ids":[],"ecosystem":"crates.io","exploited":false,"fixed_versions":["0.7.18"],"ghsa_id":"GHSA-3gjw-f78c-vvpw","id":"tcs_01M5KFBNTWKP16DCMVN0099MF8","modified_at":"2026-08-25T02:45:03.437011884Z","published_at":"2026-06-12T12:00:00Z","references":["https://osv.dev/vulnerability/RUSTSEC-2026-0178","https://crates.io/crates/tokio-postgres","https://rustsec.org/advisories/RUSTSEC-2026-0178.html","https://github.com/rust-postgres/rust-postgres/commit/7a00ffa9ad4d951ec0a4564b52f1780fa9d353c1"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"RUSTSEC-2026-0178","url":"https://osv.dev/vulnerability/RUSTSEC-2026-0178"}],"summary":"Panic on a `DataRow` with fewer fields than columns allows denial of service"}