{"action":"Upgrade postgres-protocol to 0.6.12 or later.","affected":[{"fixed":"0.6.12","introduced":"0.0.0-0"}],"component":"postgres-protocol","cve_ids":[],"ecosystem":"crates.io","exploited":false,"fixed_versions":["0.6.12"],"ghsa_id":"GHSA-rgqc-3x5p-6gwg","id":"tcs_01M5KFBP346HHJ0ZWZ9MX4QA07","modified_at":"2026-08-25T02:45:03.441978815Z","published_at":"2026-06-12T12:00:00Z","references":["https://osv.dev/vulnerability/RUSTSEC-2026-0180","https://crates.io/crates/postgres-protocol","https://rustsec.org/advisories/RUSTSEC-2026-0180.html","https://github.com/rust-postgres/rust-postgres/commit/a7cf84b5c46431cbca9d8ff50508c23f446efa7d"],"severity":{"label":"unknown"},"sources":[{"source":"osv","source_id":"RUSTSEC-2026-0180","url":"https://osv.dev/vulnerability/RUSTSEC-2026-0180"}],"summary":"Panic decoding a malformed `hstore` value allows denial of service"}