{"action":"Upgrade langflow to 1.9.0 or later.","affected":[{"fixed":"1.9.0","introduced":"0"}],"component":"langflow","cve_ids":["CVE-2026-42048"],"ecosystem":"PyPI","epss":0.04195,"exploited":false,"fixed_versions":["1.9.0"],"ghsa_id":"GHSA-9whx-c884-c68q","id":"tcs_01M5KFBQDZ8C1CQ00252VHP1AR","modified_at":"2026-06-29T12:26:10.021679892Z","published_at":"2026-05-05T18:28:59Z","references":["https://osv.dev/vulnerability/GHSA-9whx-c884-c68q","https://github.com/langflow-ai/langflow/security/advisories/GHSA-9whx-c884-c68q","https://nvd.nist.gov/vuln/detail/CVE-2026-42048","https://github.com/langflow-ai/langflow"],"severity":{"label":"critical","score":9.6},"sources":[{"source":"osv","source_id":"GHSA-9whx-c884-c68q","url":"https://osv.dev/vulnerability/GHSA-9whx-c884-c68q"}],"summary":"Langflow Knowledge Bases API is Vulnerable to Path Traversal"}