{"action":"Upgrade jupyterhub to 4.1.6 or later.","affected":[{"fixed":"4.1.6","introduced":"0"},{"fixed":"5.1.0","introduced":"5.0.0"}],"component":"jupyterhub","cve_ids":["CVE-2024-41942"],"ecosystem":"PyPI","epss":0.0059,"exploited":false,"fixed_versions":["4.1.6","5.1.0"],"ghsa_id":"GHSA-9x4q-3gxw-849f","id":"tcs_01M5KFBS2BKDNYJKBK9G99G1CA","modified_at":"2026-09-10T03:50:17.487409719Z","published_at":"2024-08-08T14:37:06Z","references":["https://osv.dev/vulnerability/GHSA-9x4q-3gxw-849f","https://github.com/jupyterhub/jupyterhub/security/advisories/GHSA-9x4q-3gxw-849f","https://nvd.nist.gov/vuln/detail/CVE-2024-41942","https://github.com/jupyterhub/jupyterhub/commit/99e2720b0fc626cbeeca3c6337f917fdacfaa428","https://github.com/jupyterhub/jupyterhub/commit/ff2db557a85b6980f90c3158634bf924063ab8ba","https://github.com/jupyterhub/jupyterhub","https://github.com/pypa/advisory-database/tree/main/vulns/jupyterhub/PYSEC-2024-200.yaml"],"severity":{"label":"high","score":7.2},"sources":[{"source":"osv","source_id":"GHSA-9x4q-3gxw-849f","url":"https://osv.dev/vulnerability/GHSA-9x4q-3gxw-849f"}],"summary":"JupyterHub has a privilege escalation vulnerability with the `admin:users` scope"}