{"action":"Upgrade vyper to 0.4.0 or later.","affected":[{"fixed":"0.4.0","introduced":"0"}],"component":"vyper","cve_ids":["CVE-2024-24561"],"ecosystem":"PyPI","epss":0.00902,"exploited":false,"fixed_versions":["0.4.0"],"ghsa_id":"GHSA-9x7f-gwxq-6f2c","id":"tcs_01M5KFBT6DTJXHZ042SPRV7M68","modified_at":"2026-09-10T03:50:06.200562960Z","published_at":"2024-02-01T20:51:32Z","references":["https://osv.dev/vulnerability/GHSA-9x7f-gwxq-6f2c","https://github.com/vyperlang/vyper/security/advisories/GHSA-9x7f-gwxq-6f2c","https://nvd.nist.gov/vuln/detail/CVE-2024-24561","https://github.com/vyperlang/vyper/issues/3756","https://github.com/pypa/advisory-database/tree/main/vulns/vyper/PYSEC-2024-149.yaml","https://github.com/vyperlang/vyper","https://github.com/vyperlang/vyper/blob/b01cd686aa567b32498fefd76bd96b0597c6f099/vyper/builtins/functions.py#L404-L457"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"GHSA-9x7f-gwxq-6f2c","url":"https://osv.dev/vulnerability/GHSA-9x7f-gwxq-6f2c"}],"summary":"Vyper's bounds check on built-in `slice()` function can be overflowed"}