{"action":"Upgrade poetry to 1.1.9 or later.","affected":[{"fixed":"1.1.9","introduced":"0"}],"component":"poetry","cve_ids":["CVE-2022-36069"],"ecosystem":"PyPI","epss":0.01357,"exploited":false,"fixed_versions":["1.1.9"],"ghsa_id":"GHSA-9xgj-fcgf-x6mw","id":"tcs_01M5KFBV0KAP9NZHDDAF6PHYNH","modified_at":"2024-10-21T21:08:19.767146Z","published_at":"2022-09-16T19:26:59Z","references":["https://osv.dev/vulnerability/GHSA-9xgj-fcgf-x6mw","https://github.com/python-poetry/poetry/security/advisories/GHSA-9xgj-fcgf-x6mw","https://nvd.nist.gov/vuln/detail/CVE-2022-36069","https://github.com/pypa/advisory-database/tree/main/vulns/poetry/PYSEC-2022-266.yaml","https://github.com/python-poetry/poetry","https://github.com/python-poetry/poetry/releases/tag/1.1.9","https://github.com/python-poetry/poetry/releases/tag/1.2.0b1","https://www.sonarsource.com/blog/securing-developer-tools-package-managers"],"severity":{"label":"high","score":7.3},"sources":[{"source":"osv","source_id":"GHSA-9xgj-fcgf-x6mw","url":"https://osv.dev/vulnerability/GHSA-9xgj-fcgf-x6mw"}],"summary":"Poetry Argument Injection can lead to Local Code Execution"}