{"action":"Upgrade tensorflow-cpu to 2.1.4 or later.","affected":[{"fixed":"2.1.4","introduced":"0"},{"fixed":"2.2.3","introduced":"2.2.0"},{"fixed":"2.3.3","introduced":"2.3.0"},{"fixed":"2.4.2","introduced":"2.4.0"}],"component":"tensorflow-cpu","cve_ids":["CVE-2021-29583"],"ecosystem":"PyPI","epss":0.00211,"exploited":false,"fixed_versions":["2.1.4","2.2.3","2.3.3","2.4.2"],"ghsa_id":"GHSA-9xh4-23q4-v6wr","id":"tcs_01M5KFBVH23S6964PEV2S58WFW","modified_at":"2026-07-08T06:27:26.631277174Z","published_at":"2021-05-21T14:26:35Z","references":["https://osv.dev/vulnerability/GHSA-9xh4-23q4-v6wr","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-9xh4-23q4-v6wr","https://nvd.nist.gov/vuln/detail/CVE-2021-29583","https://github.com/tensorflow/tensorflow/commit/6972f9dfe325636b3db4e0bc517ee22a159365c0","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-511.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-709.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-220.yaml","https://github.com/tensorflow/tensorflow"],"severity":{"label":"low","score":2.5},"sources":[{"source":"osv","source_id":"GHSA-9xh4-23q4-v6wr#PyPI/tensorflow-cpu","url":"https://osv.dev/vulnerability/GHSA-9xh4-23q4-v6wr"}],"summary":"Heap buffer overflow and undefined behavior in `FusedBatchNorm`"}