{"action":"Upgrade mongoose to 4.13.21 or later.","affected":[{"fixed":"5.7.5","introduced":"5.0.0"},{"fixed":"4.13.21","introduced":"0"}],"component":"mongoose","cve_ids":["CVE-2019-17426"],"ecosystem":"npm","epss":0.01497,"exploited":false,"fixed_versions":["5.7.5","4.13.21"],"ghsa_id":"GHSA-8687-vv9j-hgph","id":"tcs_01M5KFBYEPZGM6WQMV41ZZNMS4","modified_at":"2023-11-29T22:07:26Z","published_at":"2019-10-22T20:19:54Z","references":["https://osv.dev/vulnerability/GHSA-8687-vv9j-hgph","https://nvd.nist.gov/vuln/detail/CVE-2019-17426","https://github.com/Automattic/mongoose/issues/8222","https://github.com/Automattic/mongoose/commit/f3eca5b94d822225c04e96cbeed9f095afb3c31c","https://github.com/Automattic/mongoose/commit/f88eb2524b65a68ff893c90a03c04f0913c1913e","https://github.com/Automattic/mongoose","https://github.com/Automattic/mongoose/commits/4.13.21","https://github.com/Automattic/mongoose/releases/tag/4.13.21"],"severity":{"label":"critical","score":9.1},"sources":[{"source":"osv","source_id":"GHSA-8687-vv9j-hgph","url":"https://osv.dev/vulnerability/GHSA-8687-vv9j-hgph"}],"summary":"Improper Input Validation in Automattic Mongoose"}