{"action":"Upgrade requests to 2.3.0 or later.","affected":[{"fixed":"2.3.0","introduced":"0"}],"component":"requests","cve_ids":["CVE-2014-1829"],"ecosystem":"PyPI","epss":0.022,"exploited":false,"fixed_versions":["2.3.0"],"ghsa_id":"GHSA-cfj3-7x9c-4p3h","id":"tcs_01M5KFCTK4KVEFW7YC4PNHC62K","modified_at":"2024-10-26T22:51:23.384075Z","published_at":"2022-05-17T03:49:35Z","references":["https://osv.dev/vulnerability/GHSA-cfj3-7x9c-4p3h","https://nvd.nist.gov/vuln/detail/CVE-2014-1829","https://github.com/kennethreitz/requests/issues/1885","https://github.com/psf/requests/issues/1885","https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=733108","https://github.com/advisories/GHSA-cfj3-7x9c-4p3h","https://github.com/psf/requests","https://github.com/pypa/advisory-database/tree/main/vulns/requests/PYSEC-2014-13.yaml","https://web.archive.org/web/20150523055216/http://www.mandriva.com/en/support/security/advisories/advisory/MDVSA-2015:133/?name=MDVSA-2015:133","http://advisories.mageia.org/MGASA-2014-0409.html","http://www.debian.org/security/2015/dsa-3146","http://www.mandriva.com/security/advisories?name=MDVSA-2015:133","http://www.ubuntu.com/usn/USN-2382-1"],"severity":{"label":"medium","score":5.3},"sources":[{"source":"osv","source_id":"GHSA-cfj3-7x9c-4p3h","url":"https://osv.dev/vulnerability/GHSA-cfj3-7x9c-4p3h"}],"summary":"Exposure of Sensitive Information to an Unauthorized Actor in Requests"}