{"action":"Upgrade https-proxy-agent to 2.2.0 or later.","affected":[{"fixed":"2.2.0","introduced":"0"}],"component":"https-proxy-agent","cve_ids":["CVE-2018-3739"],"ecosystem":"npm","epss":0.01735,"exploited":false,"fixed_versions":["2.2.0"],"ghsa_id":"GHSA-8g7p-74h8-hg48","id":"tcs_01M5KFCVQQ082J6PZTK460V8K8","modified_at":"2026-09-10T03:46:37.019903328Z","published_at":"2018-07-27T17:04:52Z","references":["https://osv.dev/vulnerability/GHSA-8g7p-74h8-hg48","https://nvd.nist.gov/vuln/detail/CVE-2018-3736","https://github.com/TooTallNate/node-https-proxy-agent/commit/1c24219df87524e6ed973127e81f30801d658f07","https://hackerone.com/reports/319532","https://github.com/TooTallNate/node-https-proxy-agent","https://github.com/advisories/GHSA-8g7p-74h8-hg48","https://www.npmjs.com/advisories/593"],"severity":{"label":"critical","score":9.1},"sources":[{"source":"osv","source_id":"GHSA-8g7p-74h8-hg48","url":"https://osv.dev/vulnerability/GHSA-8g7p-74h8-hg48"}],"summary":"Denial of Service in https-proxy-agent"}