{"action":"Upgrade skywalking-backend-js to 0.5.1 or later.","affected":[{"fixed":"0.5.1","introduced":"0"}],"component":"skywalking-backend-js","cve_ids":["CVE-2022-36127"],"ecosystem":"npm","epss":0.01866,"exploited":false,"fixed_versions":["0.5.1"],"ghsa_id":"GHSA-8gpg-466c-5cpj","id":"tcs_01M5KFCXQ3DM50PHF8GTDBS9JZ","modified_at":"2023-11-08T04:10:01.963006Z","published_at":"2022-07-19T00:00:27Z","references":["https://osv.dev/vulnerability/GHSA-8gpg-466c-5cpj","https://nvd.nist.gov/vuln/detail/CVE-2022-36127","https://github.com/apache/skywalking-nodejs","https://lists.apache.org/thread/x238wo4r5goy39dxdjcmlofp6gcdnqr3","https://skywalking.apache.org/events/release-apache-skywalking-nodejs-0-5-1","http://www.openwall.com/lists/oss-security/2022/07/18/1"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-8gpg-466c-5cpj","url":"https://osv.dev/vulnerability/GHSA-8gpg-466c-5cpj"}],"summary":"Apache SkyWalking NodeJS Agent can lose availability if header includes illegal SkyWalking header"}