{"action":"Upgrade apache-airflow to 2.7.2 or later.","affected":[{"fixed":"2.7.2","introduced":"0"}],"component":"apache-airflow","cve_ids":["CVE-2023-42780"],"ecosystem":"PyPI","epss":0.01439,"exploited":false,"fixed_versions":["2.7.2"],"ghsa_id":"GHSA-cgx2-rrmr-jx43","id":"tcs_01M5KFD1962X7CCTRYQZHKWCMX","modified_at":"2024-09-03T21:45:49.702558Z","published_at":"2023-10-14T12:30:23Z","references":["https://osv.dev/vulnerability/GHSA-cgx2-rrmr-jx43","https://nvd.nist.gov/vuln/detail/CVE-2023-42780","https://github.com/apache/airflow/pull/34355","https://github.com/apache/airflow/commit/cf4eb3fb9b5cf4a8369b890e39523d4c05eed161","https://github.com/apache/airflow","https://github.com/pypa/advisory-database/tree/main/vulns/apache-airflow/PYSEC-2023-202.yaml","https://lists.apache.org/thread/h5tvsvov8j55wojt5sojdprs05oby34d"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"GHSA-cgx2-rrmr-jx43","url":"https://osv.dev/vulnerability/GHSA-cgx2-rrmr-jx43"}],"summary":"Apache Airflow vulnerable to sensitive information exposure when users list warnings for all DAGs"}