{"action":"Upgrade next to 15.5.16 or later.","affected":[{"fixed":"15.5.16","introduced":"13.0.0"},{"fixed":"16.2.5","introduced":"16.0.0"}],"component":"next","cve_ids":[],"ecosystem":"npm","exploited":false,"fixed_versions":["15.5.16","16.2.5"],"ghsa_id":"GHSA-8h8q-6873-q5fj","id":"tcs_01M5KFD1SKBZRXHBMJJ5MM22YN","modified_at":"2026-09-10T03:51:04.979274056Z","published_at":"2026-05-11T14:50:27Z","references":["https://osv.dev/vulnerability/GHSA-8h8q-6873-q5fj","https://github.com/facebook/react/security/advisories/GHSA-rv78-f8rc-xrxh","https://github.com/vercel/next.js/security/advisories/GHSA-8h8q-6873-q5fj","https://github.com/vitejs/vite-plugin-react/security/advisories/GHSA-w94c-4vhp-22gx","https://nvd.nist.gov/vuln/detail/CVE-2026-23870","https://github.com/vercel/next.js"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-8h8q-6873-q5fj","url":"https://osv.dev/vulnerability/GHSA-8h8q-6873-q5fj"}],"summary":"Next.js Vulnerable to Denial of Service with Server Components"}