{"action":"Upgrade proxy-py to 2.3.1 or later.","affected":[{"fixed":"2.3.1","introduced":"0"}],"component":"proxy-py","cve_ids":["CVE-2021-3116"],"ecosystem":"PyPI","epss":0.01694,"exploited":false,"fixed_versions":["2.3.1"],"ghsa_id":"GHSA-cmc7-mfmr-xqrx","id":"tcs_01M5KFDB2E8R2CCFRB31BG6H17","modified_at":"2024-10-21T21:23:38.100628Z","published_at":"2021-04-07T21:01:25Z","references":["https://osv.dev/vulnerability/GHSA-cmc7-mfmr-xqrx","https://nvd.nist.gov/vuln/detail/CVE-2021-3116","https://github.com/abhinavsingh/proxy.py/pull/482","https://github.com/abhinavsingh/proxy.py/pull/482/commits/9b00093288237f5073c403f2c4f62acfdfa8ed46","https://github.com/abhinavsingh/proxy.py/commit/bff171ec26d826ae1d22d2466eaf9d8bdbf059d3","https://cardaci.xyz/advisories/2021/01/10/proxy.py-2.3.0-broken-basic-authentication","https://github.com/abhinavsingh/proxy.py","https://github.com/advisories/GHSA-cmc7-mfmr-xqrx","https://github.com/pypa/advisory-database/tree/main/vulns/proxy-py/PYSEC-2021-46.yaml","https://pypi.org/project/proxy.py/2.3.1/#history"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-cmc7-mfmr-xqrx","url":"https://osv.dev/vulnerability/GHSA-cmc7-mfmr-xqrx"}],"summary":"Logic error in authentication in proxy.py"}