{"action":"Upgrade matrix-synapse to 1.5.0 or later.","affected":[{"fixed":"1.5.0","introduced":"0"}],"component":"matrix-synapse","cve_ids":["CVE-2019-18835"],"ecosystem":"PyPI","epss":0.00864,"exploited":false,"fixed_versions":["1.5.0"],"ghsa_id":"GHSA-cppw-2mf8-qpm5","id":"tcs_01M5KFDDK08WKQHSPRD1KQSSMG","modified_at":"2025-02-15T05:30:05.833872Z","published_at":"2022-05-24T22:01:05Z","references":["https://osv.dev/vulnerability/GHSA-cppw-2mf8-qpm5","https://nvd.nist.gov/vuln/detail/CVE-2019-18835","https://github.com/matrix-org/synapse/pull/6262","https://github.com/matrix-org/synapse/commit/172f264ed38e8bef857552f93114b4ee113a880b","https://github.com/matrix-org/synapse","https://github.com/matrix-org/synapse/releases/tag/v1.5.0","https://github.com/pypa/advisory-database/tree/main/vulns/matrix-synapse/PYSEC-2019-186.yaml"],"severity":{"label":"high","score":8.6},"sources":[{"source":"osv","source_id":"GHSA-cppw-2mf8-qpm5","url":"https://osv.dev/vulnerability/GHSA-cppw-2mf8-qpm5"}],"summary":"Improper Verification of Cryptographic Signature in matrix-synapse"}