{"action":"Upgrade python-cjson to 1.0.5.1 or later.","affected":[{"fixed":"1.0.5.1","introduced":"0"}],"component":"python-cjson","cve_ids":["CVE-2010-1666"],"ecosystem":"PyPI","epss":0.01665,"exploited":false,"fixed_versions":["1.0.5.1"],"ghsa_id":"GHSA-cqmh-mpx2-g633","id":"tcs_01M5KFDHHVD465E11ABZ59YZ7S","modified_at":"2024-10-15T17:00:54.813578Z","published_at":"2022-05-17T05:49:38Z","references":["https://osv.dev/vulnerability/GHSA-cqmh-mpx2-g633","https://nvd.nist.gov/vuln/detail/CVE-2010-1666","https://github.com/AGProjects/python-cjson/commit/dc2b8781b8666de5ca707318521f554904fdd690","https://bugs.launchpad.net/ubuntu/+source/python-cjson/+bug/585274","https://github.com/AGProjects/python-cjson","https://github.com/pypa/advisory-database/tree/main/vulns/python-cjson/PYSEC-2010-30.yaml","http://www.debian.org/security/2010/dsa-2068"],"severity":{"label":"medium"},"sources":[{"source":"osv","source_id":"GHSA-cqmh-mpx2-g633","url":"https://osv.dev/vulnerability/GHSA-cqmh-mpx2-g633"}],"summary":"Improper Restriction of Operations within the Bounds of a Memory Buffer in python-cjson"}