{"action":"Upgrade octoprint to 1.11.4 or later.","affected":[{"fixed":"1.11.4","introduced":"0"}],"component":"octoprint","cve_ids":["CVE-2025-64187"],"ecosystem":"PyPI","epss":0.00169,"exploited":false,"fixed_versions":["1.11.4"],"ghsa_id":"GHSA-crvm-xjhm-9h29","id":"tcs_01M5KFDP7Q2207EKKBZGTMYB87","modified_at":"2026-07-07T17:57:31.794332097Z","published_at":"2025-11-04T15:42:48Z","references":["https://osv.dev/vulnerability/GHSA-crvm-xjhm-9h29","https://github.com/OctoPrint/OctoPrint/security/advisories/GHSA-crvm-xjhm-9h29","https://nvd.nist.gov/vuln/detail/CVE-2025-64187","https://github.com/OctoPrint/OctoPrint/commit/9112e07b1085f4c1ee9eefc67985809251057a44","https://github.com/OctoPrint/OctoPrint"],"severity":{"label":"medium","score":4.4},"sources":[{"source":"osv","source_id":"GHSA-crvm-xjhm-9h29","url":"https://osv.dev/vulnerability/GHSA-crvm-xjhm-9h29"},{"source":"nvd","source_id":"CVE-2025-64187","url":"https://nvd.nist.gov/vuln/detail/CVE-2025-64187"}],"summary":"OctoPrint vulnerable to XSS in Action Commands Notification and Prompt"}