{"action":"Upgrade dulwich to 0.18.5 or later.","affected":[{"fixed":"0.18.5","introduced":"0"}],"component":"dulwich","cve_ids":["CVE-2017-16228"],"ecosystem":"PyPI","epss":0.03706,"exploited":false,"fixed_versions":["0.18.5"],"ghsa_id":"GHSA-cwwh-4382-6fwr","id":"tcs_01M5KFDZFN6NN3F763TPQ1BTK0","modified_at":"2024-11-30T05:33:25.494557Z","published_at":"2022-05-13T01:44:04Z","references":["https://osv.dev/vulnerability/GHSA-cwwh-4382-6fwr","https://nvd.nist.gov/vuln/detail/CVE-2017-16228","https://github.com/jelmer/dulwich/commit/7116a0cbbda571f7dac863f4b1c00b6e16d6d8d6","https://github.com/jelmer/dulwich","https://github.com/pypa/advisory-database/tree/main/vulns/dulwich/PYSEC-2017-12.yaml","https://tracker.debian.org/news/882440","https://web.archive.org/web/20201220231743/https://www.dulwich.io/code/dulwich/commit/7116a0cbbda571f7dac863f4b1c00b6e16d6d8d6","https://web.archive.org/web/20210128154006/https://www.dulwich.io/code/dulwich","https://www.dulwich.io/code/dulwich","https://www.dulwich.io/code/dulwich/commit/7116a0cbbda571f7dac863f4b1c00b6e16d6d8d6"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"GHSA-cwwh-4382-6fwr","url":"https://osv.dev/vulnerability/GHSA-cwwh-4382-6fwr"}],"summary":"Dulwich RCE Vulnerability"}