{"action":"Upgrade setuptools to 70.0.0 or later.","affected":[{"fixed":"70.0.0","introduced":"0"}],"component":"setuptools","cve_ids":["CVE-2024-6345"],"ecosystem":"PyPI","epss":0.01939,"exploited":false,"fixed_versions":["70.0.0"],"ghsa_id":"GHSA-cx63-2mw6-8hw5","id":"tcs_01M5KFE0SVQVZDHK4AN26D8ZXJ","modified_at":"2026-09-10T03:50:16.663495061Z","published_at":"2024-07-15T03:30:57Z","references":["https://osv.dev/vulnerability/GHSA-cx63-2mw6-8hw5","https://nvd.nist.gov/vuln/detail/CVE-2024-6345","https://github.com/pypa/setuptools/pull/4332","https://github.com/pypa/setuptools/commit/88807c7062788254f654ea8c03427adc859321f0","https://github.com/pypa/setuptools","https://huntr.com/bounties/d6362117-ad57-4e83-951f-b8141c6e7ca5","https://lists.debian.org/debian-lts-announce/2024/09/msg00018.html"],"severity":{"label":"high","score":8.8},"sources":[{"source":"osv","source_id":"GHSA-cx63-2mw6-8hw5","url":"https://osv.dev/vulnerability/GHSA-cx63-2mw6-8hw5"}],"summary":"setuptools vulnerable to Command Injection via package URL"}