{"action":"Upgrade blackduck to 0.0.53 or later.","affected":[{"fixed":"0.0.53","introduced":"0.0.25"}],"component":"blackduck","cve_ids":["CVE-2020-27589"],"ecosystem":"PyPI","epss":0.01126,"exploited":false,"fixed_versions":["0.0.53"],"ghsa_id":"GHSA-f248-v4qh-x2r6","id":"tcs_01M5KFE2PKPDGMM87C0N10TB1H","modified_at":"2024-09-13T18:02:52.911555Z","published_at":"2021-04-20T16:29:41Z","references":["https://osv.dev/vulnerability/GHSA-f248-v4qh-x2r6","https://nvd.nist.gov/vuln/detail/CVE-2020-27589","https://github.com/blackducksoftware/hub-rest-api-python/pull/113","https://github.com/blackducksoftware/hub-rest-api-python/commit/0a25777117515b8b4ff287a98f57837a8c6bdbdb","https://community.synopsys.com/s/question/0D52H00005JCZAXSA5/announcement-black-duck-defect-identified","https://github.com/advisories/GHSA-f248-v4qh-x2r6","https://github.com/blackducksoftware/hub-rest-api-python","https://github.com/pypa/advisory-database/tree/main/vulns/blackduck/PYSEC-2020-26.yaml","https://pypi.org/project/blackduck","https://www.optiv.com/explore-optiv-insights/source-zero/certificate-validation-disabled-black-duck-api-wrapper"],"severity":{"label":"high","score":7.5},"sources":[{"source":"osv","source_id":"GHSA-f248-v4qh-x2r6","url":"https://osv.dev/vulnerability/GHSA-f248-v4qh-x2r6"}],"summary":"Improper Certificate Validation in blackduck"}