{"action":"Upgrade tensorflow-cpu to 2.5.3 or later.","affected":[{"fixed":"2.5.3","introduced":"0"},{"fixed":"2.6.3","introduced":"2.6.0"},{"fixed":"2.7.1","introduced":"2.7.0"}],"component":"tensorflow-cpu","cve_ids":["CVE-2022-21737"],"ecosystem":"PyPI","epss":0.00789,"exploited":false,"fixed_versions":["2.5.3","2.6.3","2.7.1"],"ghsa_id":"GHSA-f2vv-v9cg-qhh7","id":"tcs_01M5KFE5QBD2DTRTSTQT5BB6TB","modified_at":"2026-09-10T03:48:32.526405590Z","published_at":"2022-02-09T23:43:48Z","references":["https://osv.dev/vulnerability/GHSA-f2vv-v9cg-qhh7","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-f2vv-v9cg-qhh7","https://nvd.nist.gov/vuln/detail/CVE-2022-21737","https://github.com/tensorflow/tensorflow/commit/7019ce4f68925fd01cdafde26f8d8c938f47e6f9","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2022-61.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2022-116.yaml","https://github.com/tensorflow/tensorflow","https://github.com/tensorflow/tensorflow/blob/5100e359aef5c8021f2e71c7b986420b85ce7b3d/tensorflow/core/kernels/bincount_op.cc"],"severity":{"label":"medium","score":6.5},"sources":[{"source":"osv","source_id":"GHSA-f2vv-v9cg-qhh7#PyPI/tensorflow-cpu","url":"https://osv.dev/vulnerability/GHSA-f2vv-v9cg-qhh7"}],"summary":"Assertion failure based denial of service in Tensorflow"}