{"action":"Upgrade tensorflow-gpu to 2.6.4 or later.","affected":[{"fixed":"2.6.4","introduced":"0"},{"fixed":"2.7.2","introduced":"2.7.0"},{"fixed":"2.8.1","introduced":"2.8.0"}],"component":"tensorflow-gpu","cve_ids":["CVE-2022-29209"],"ecosystem":"PyPI","epss":0.00395,"exploited":false,"fixed_versions":["2.6.4","2.7.2","2.8.1"],"ghsa_id":"GHSA-f4rr-5m7v-wxcw","id":"tcs_01M5KFEDHS7RTJE4W3HFB7F9Y9","modified_at":"2026-07-13T16:42:25.790608153Z","published_at":"2022-05-24T22:14:44Z","references":["https://osv.dev/vulnerability/GHSA-f4rr-5m7v-wxcw","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-f4rr-5m7v-wxcw","https://nvd.nist.gov/vuln/detail/CVE-2022-29209","https://github.com/tensorflow/tensorflow/issues/55530","https://github.com/tensorflow/tensorflow/pull/55730","https://github.com/tensorflow/tensorflow/commit/b917181c29b50cb83399ba41f4d938dc369109a1","https://github.com/tensorflow/tensorflow","https://github.com/tensorflow/tensorflow/blob/f3b9bf4c3c0597563b289c0512e98d4ce81f886e/tensorflow/core/platform/default/logging.h","https://github.com/tensorflow/tensorflow/releases/tag/v2.6.4","https://github.com/tensorflow/tensorflow/releases/tag/v2.7.2","https://github.com/tensorflow/tensorflow/releases/tag/v2.8.1","https://github.com/tensorflow/tensorflow/releases/tag/v2.9.0"],"severity":{"label":"medium","score":5.5},"sources":[{"source":"osv","source_id":"GHSA-f4rr-5m7v-wxcw#PyPI/tensorflow-gpu","url":"https://osv.dev/vulnerability/GHSA-f4rr-5m7v-wxcw"}],"summary":"Type confusion leading to `CHECK`-failure based denial of service in TensorFlow"}