{"action":"Upgrade pyshop to 0.7.1 or later.","affected":[{"fixed":"0.7.1","introduced":"0"}],"component":"pyshop","cve_ids":["CVE-2013-1630"],"ecosystem":"PyPI","epss":0.021,"exploited":false,"fixed_versions":["0.7.1"],"ghsa_id":"GHSA-f594-f3v3-g649","id":"tcs_01M5KFEGDVJVSQQK0E3SS81JQP","modified_at":"2024-10-14T18:36:24.594642Z","published_at":"2022-05-17T05:03:06Z","references":["https://osv.dev/vulnerability/GHSA-f594-f3v3-g649","https://nvd.nist.gov/vuln/detail/CVE-2013-1630","https://github.com/mardiros/pyshop/commit/ffadb0bcdef1e385884571670210cfd6ba351784","https://github.com/mardiros/pyshop","https://github.com/mardiros/pyshop/blob/master/CHANGES.txt","https://github.com/pypa/advisory-database/tree/main/vulns/pyshop/PYSEC-2013-10.yaml","http://www.reddit.com/r/Python/comments/17rfh7/warning_dont_use_pip_in_an_untrusted_network_a"],"severity":{"label":"high"},"sources":[{"source":"osv","source_id":"GHSA-f594-f3v3-g649","url":"https://osv.dev/vulnerability/GHSA-f594-f3v3-g649"}],"summary":"pyshop vulnerable to man-in-the-middle attacks due to using HTTP to retrieve packages from the PyPI repository"}