{"action":"Upgrade github.com/mattermost/mattermost-server to 4.1.2 or later.","affected":[{"fixed":"4.1.2","introduced":"0"},{"fixed":"4.2.1","introduced":"4.2.0-rc1"},{"fixed":"4.3.0","introduced":"4.3.0-rc1"}],"component":"github.com/mattermost/mattermost-server","cve_ids":["CVE-2017-18889"],"ecosystem":"Go","epss":0.00669,"exploited":false,"fixed_versions":["4.1.2","4.2.1","4.3.0"],"ghsa_id":"GHSA-jp57-4x34-5v94","id":"tcs_01M5KFEGWF2T4RQ8Y2X862Y35B","modified_at":"2025-12-15T20:25:58.315781Z","published_at":"2022-05-24T17:21:04Z","references":["https://osv.dev/vulnerability/GHSA-jp57-4x34-5v94","https://nvd.nist.gov/vuln/detail/CVE-2017-18889","https://github.com/mattermost/mattermost","https://mattermost.com/security-updates"],"severity":{"label":"medium","score":4.3},"sources":[{"source":"osv","source_id":"GHSA-jp57-4x34-5v94","url":"https://osv.dev/vulnerability/GHSA-jp57-4x34-5v94"}],"summary":"Mattermost Server is vulnerable to webhook and slash command manipulation"}