{"action":"Upgrade numexpr to 2.8.5 or later.","affected":[{"fixed":"2.8.5","introduced":"0"}],"component":"numexpr","cve_ids":["CVE-2023-39631"],"ecosystem":"PyPI","epss":0.016,"exploited":false,"fixed_versions":["2.8.5"],"ghsa_id":"GHSA-f73w-4m7g-ch9x","id":"tcs_01M5KFEN1ZFAXF2WS9N4PWH8VY","modified_at":"2025-02-20T23:01:00.348246Z","published_at":"2023-09-01T18:30:41Z","references":["https://osv.dev/vulnerability/GHSA-f73w-4m7g-ch9x","https://nvd.nist.gov/vuln/detail/CVE-2023-39631","https://github.com/langchain-ai/langchain/issues/8363","https://github.com/pydata/numexpr/issues/442","https://github.com/langchain-ai/langchain/pull/11302","https://github.com/pydata/numexpr/commit/4b2d89cf14e75030d27629925b9998e1e91d23c7","https://github.com/langchain-ai/langchain","https://github.com/langchain-ai/langchain/releases/tag/v0.0.308","https://github.com/pypa/advisory-database/tree/main/vulns/langchain/PYSEC-2023-162.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/numexpr/PYSEC-2023-163.yaml"],"severity":{"label":"critical","score":9.8},"sources":[{"source":"osv","source_id":"GHSA-f73w-4m7g-ch9x#PyPI/numexpr","url":"https://osv.dev/vulnerability/GHSA-f73w-4m7g-ch9x"}],"summary":"Langchain vulnerable to arbitrary code execution via the evaluate function in the numexpr library"}