{"action":"Upgrade tensorflow-gpu to 2.1.4 or later.","affected":[{"fixed":"2.1.4","introduced":"0"},{"fixed":"2.2.3","introduced":"2.2.0"},{"fixed":"2.3.3","introduced":"2.3.0"},{"fixed":"2.4.2","introduced":"2.4.0"}],"component":"tensorflow-gpu","cve_ids":["CVE-2021-29550"],"ecosystem":"PyPI","epss":0.00189,"exploited":false,"fixed_versions":["2.1.4","2.2.3","2.3.3","2.4.2"],"ghsa_id":"GHSA-f78g-q7r4-9wcv","id":"tcs_01M5KFEP17DZ2WTX4GEJNRYMFW","modified_at":"2026-07-08T06:28:55.334053984Z","published_at":"2021-05-21T14:23:41Z","references":["https://osv.dev/vulnerability/GHSA-f78g-q7r4-9wcv","https://github.com/tensorflow/tensorflow/security/advisories/GHSA-f78g-q7r4-9wcv","https://nvd.nist.gov/vuln/detail/CVE-2021-29550","https://github.com/tensorflow/tensorflow/commit/548b5eaf23685d86f722233d8fbc21d0a4aecb96","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-cpu/PYSEC-2021-478.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow-gpu/PYSEC-2021-676.yaml","https://github.com/pypa/advisory-database/tree/main/vulns/tensorflow/PYSEC-2021-187.yaml","https://github.com/tensorflow/tensorflow"],"severity":{"label":"low","score":2.5},"sources":[{"source":"osv","source_id":"GHSA-f78g-q7r4-9wcv#PyPI/tensorflow-gpu","url":"https://osv.dev/vulnerability/GHSA-f78g-q7r4-9wcv"}],"summary":"Division by 0 in `FractionalAvgPool`"}