{"action":"Upgrade vega-functions to 5.17.0 or later.","affected":[{"fixed":"5.17.0","introduced":"0"}],"component":"vega-functions","cve_ids":["CVE-2025-27793"],"ecosystem":"npm","epss":0.00517,"exploited":false,"fixed_versions":["5.17.0"],"ghsa_id":"GHSA-963h-3v39-3pqf","id":"tcs_01M5KFEYGT65MYCRW29ARE0JD9","modified_at":"2025-03-27T18:08:39.051781Z","published_at":"2025-03-27T18:00:24Z","references":["https://osv.dev/vulnerability/GHSA-963h-3v39-3pqf","https://github.com/vega/vega/security/advisories/GHSA-963h-3v39-3pqf","https://nvd.nist.gov/vuln/detail/CVE-2025-27793","https://github.com/vega/vega/commit/694560c0aa576df8b6c5f0f7d202ac82233e6966","https://github.com/vega/vega","https://github.com/vega/vega/releases/tag/v5.32.0","https://vega.github.io/vega/usage/interpreter"],"severity":{"label":"medium","score":5.3},"sources":[{"source":"osv","source_id":"GHSA-963h-3v39-3pqf#npm/vega-functions","url":"https://osv.dev/vulnerability/GHSA-963h-3v39-3pqf"},{"source":"nvd","source_id":"CVE-2025-27793","url":"https://nvd.nist.gov/vuln/detail/CVE-2025-27793"}],"summary":"Vega vulnerable to Cross-site Scripting via RegExp.prototype[@@replace]"}